Skip to Knowledge Base content

Outlook Web App - Web Browser Access

Issue/Question

How do I access my Exchange account outside of work/ on a non work computer?

Environment

  • Oregon State
    • Employee
      • Outlook Web App

Cause

You may find yourself off campus, on a computer with a version of Outlook that is no longer supported, or having difficuluties with your Exchange application of choice and need to check your Exchange account.

Resolution

​1. Go to exmail.oregonstate.edu 

2. Log in to the site with your username and password; for most people your username will be formatted as ONIDusername@oregonstate.edu:

You are now signed into the Outlook Web App!

If you need any assistance, feel free to call the Service Desk at 541-737-8787.

Details

Article ID: 45933
Created
Mon 1/8/18 2:48 PM
Modified
Fri 3/30/18 9:25 AM