Mailman - Troubleshoot Message Delivery

Tags mailman

Issue/Question

  • A message sent to a Mailman list was not delivered to the list members.

Environment

  • Oregon State University
  • Mailman (lists.oregonstate.edu)

Cause

There are several possible reasons that a list message might not be delivered. See below for troubleshooting and resolution steps.

Resolution

Message sent to wrong address

The message may have been sent to the wrong address for the list. For example, a message sent to listname-bounces@lists.oregonstate.edu will not be delivered because that is the special bounce processing address for the list. 

Messages should be addressed to listname@lists.oregonstate.edu, where "listname" is the name of the list.

Message rejected or discarded

If the list is configured to reject messages from non-approved senders, the sender will receive a rejection notice. If the list is configured to discard messages from non-approved senders, the sender will receive no notice. 

To view and adjust the list sender filters, the administrator can follow these steps:

  1. Go to lists.oregonstate.edu
  2. Enter the list name, and click "Manage List"
  3. Login with the list administration password
  4. Select "Privacy Options", "Sender Filters"
  5. Review member_moderation_action and generic_nonmember_action:
    1. Hold - hold for moderation
    2. Reject - reject the message and notify the sender
    3. Discard - reject the message without notifying the sender
  6. The setting forward_auto_discards can be set to "Yes" to notify the list moderator when a message is automatically discarded

Message Held for Moderation

There are a few ways that a message could be held for moderation:

  1. The sender is a member of the list and moderation is enabled for them
    • Check under "Membership Management"
    • To disable moderation for a list member, uncheck the "Mod" box and click "Submit Your Changes" at the bottom of the screen
  2. The sender is not a member of the list, generic_nonmember_action is set to "Hold", and the sender is not listed in accept_these_nonmembers
  3. The sender is not a member of the list and they are listed in hold_these_nonmembers

To allow a message that has been held for moderation, login to the list administration interface and select "Tend to pending moderator requests."

 

For assistance, contact the IS Service Desk.

Details

Article ID: 78643
Created
Mon 5/20/19 3:14 PM
Modified
Mon 5/20/19 3:27 PM