Issue/Question
How do I access my Exchange email from any web browser?
Environment
Cause
You may find yourself off campus, on a computer with a version of Outlook that is no longer supported, or having difficulties with your Exchange application of choice and need to check your Exchange account.
Resolution
- In a web browser, go to https://outlook.office.com/
- Enter in ONIDusername@oregonstate.edu and click Next and then you will be redirected to put in your password.

- At the Microsoft Federation Services page to enter in your ONID password and click Sign In.

- You can stay signed in by selecting Yes but if this is a public computer select No.

- You are now signed into the Outlook on the Web App!
For assistance, contact the IS Service Desk.