ONID - Account Activation Issues

Issue

  • I can't activate my ONID
  • ONID activation error "No matching identity found. Please check your information and try again."
  • I am unable to activate my ONID account.

Environment

  • Oregon State University
  • ONID account

Cause

All new students, employees and associates are added to OSU's ERP system known as Banner. In order to activate an ONID account, your information in Banner - OSU ID, and birth date - must be correct. You must also be eligible for an ONID account (See ONID Account Eligibility and Duration).

Resolution

Make sure that you are entering your information correctly.

  • OSU ID Number: this will be a 9-digit number provided to you in your admissions or new hire paperwork
  • Birth Date: make sure to enter month and day in the correct fields

If you are sure your information is correct and that you are eligible for ONID, you will need to confirm your information in Banner by contacting one of the groups below:

  • Students: Contact the Office of the Registrar to confirm that your information in Banner is correct.
  • Employees: Contact the person in your department who coordinates hiring, or contact your department's business center.
  • Associates and Sponsored Accounts: Contact the organization that told you about your ONID account / OSU ID number. If you are not sure who to contact, contact the ID Center.

While the ONID account creation process runs every 2 hours, please note that any changes to information in Banner (e.g. date of birth, name) will not be updated in your ONID account right away. ONID pulls this information from Banner once per day. After confirming that your Banner information has been corrected, please wait until the next day to attempt activating your ONID again.

Assistance

For assistance, contact the Service Desk.